<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="profile" href="https://gmpg.org/xfn/11" />
	<link rel="pingback" href="http://www.lutherregister.news/xmlrpc.php" />
	<script>var et_site_url='http://www.lutherregister.news';var et_post_id='19449';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>ELECTION 2020: Sharp Draws Primary Challenger</title>
<script>window._wca = window._wca || [];</script>
<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel="alternate" type="application/rss+xml" title="Luther Register News &raquo; Feed" href="http://www.lutherregister.news/feed/" />
<link rel="alternate" type="application/rss+xml" title="Luther Register News &raquo; Comments Feed" href="http://www.lutherregister.news/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Luther Register News &raquo; ELECTION 2020: Sharp Draws Primary Challenger Comments Feed" href="http://www.lutherregister.news/2020/02/07/election-2020-sharp-draws-primary-challenger/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://www.lutherregister.news/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='http://www.lutherregister.news/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wc-block-style-css'  href='http://www.lutherregister.news/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='amo-team-showcase-css'  href='http://www.lutherregister.news/wp-content/plugins/amo-team-showcase/public/css/amo-team-showcase-public.css' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_fonts-css'  href='http://www.lutherregister.news/wp-content/plugins/photo-gallery/css/bwg-fonts/fonts.css' type='text/css' media='all' />
<link rel='stylesheet' id='sumoselect-css'  href='http://www.lutherregister.news/wp-content/plugins/photo-gallery/css/sumoselect.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mCustomScrollbar-css'  href='http://www.lutherregister.news/wp-content/plugins/photo-gallery/css/jquery.mCustomScrollbar.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_googlefonts-css'  href='https://fonts.googleapis.com/css?family=Ubuntu&#038;subset=greek%2Clatin%2Cgreek-ext%2Cvietnamese%2Ccyrillic-ext%2Clatin-ext%2Ccyrillic' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_frontend-css'  href='http://www.lutherregister.news/wp-content/plugins/photo-gallery/css/styles.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='taqyeem-buttons-style-css'  href='http://www.lutherregister.news/wp-content/plugins/taqyeem-buttons/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-css-woocommerce-css'  href='http://www.lutherregister.news/wp-content/themes/jannah/assets/css/woocommerce.css' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='wpbdp_font_awesome-css'  href='https://use.fontawesome.com/releases/v5.6.3/css/all.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpbdp-widgets-css'  href='http://www.lutherregister.news/wp-content/plugins/business-directory-plugin/assets/css/widgets.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-css-styles-css'  href='http://www.lutherregister.news/wp-content/themes/jannah/assets/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-css-ilightbox-css'  href='http://www.lutherregister.news/wp-content/themes/jannah/assets/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<style id='tie-css-ilightbox-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='default-styles-css'  href='http://www.lutherregister.news/wp-content/plugins/business-directory-plugin/themes/default/assets/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.lutherregister.news/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"is_rtl":"","ajaxurl":"http:\/\/www.lutherregister.news\/wp-admin\/admin-ajax.php","mobile_menu_active":"true","mobile_menu_top":"1","mobile_menu_parent":"","lightbox_all":"true","lightbox_gallery":"true","lightbox_skin":"dark","lightbox_thumb":"horizontal","lightbox_arrows":"true","is_singular":"1","is_sticky_video":"","reading_indicator":"true","lazyload":"","select_share":"true","select_share_twitter":"true","select_share_facebook":"true","select_share_linkedin":"","select_share_email":"true","facebook_app_id":"","twitter_username":"@berryholler","responsive_tables":"true","ad_blocker_detector":"true","sticky_behavior":"default","sticky_desktop":"true","sticky_mobile":"true","sticky_mobile_behavior":"default","ajax_loader":"<div class=\"loader-overlay\">\n\t\t\t\t<div class=\"spinner\">\n\t\t\t\t\t<div class=\"bounce1\"><\/div>\n\t\t\t\t\t<div class=\"bounce2\"><\/div>\n\t\t\t\t\t<div class=\"bounce3\"> <\/div>\n\t\t\t\t<\/div>\n\t\t\t<\/div>","type_to_search":"","lang_no_results":"Nothing Found"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js'></script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-content/plugins/photo-gallery/js/jquery.mobile.min.js'></script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js'></script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-content/plugins/photo-gallery/js/jquery.fullscreen-0.4.1.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bwg_objectsL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search.","bwg_select_tag":"Select Tag","bwg_order_by":"Order By","bwg_search":"Search","bwg_show_ecommerce":"Show Ecommerce","bwg_hide_ecommerce":"Hide Ecommerce","bwg_show_comments":"Show Comments","bwg_hide_comments":"Hide Comments","bwg_restore":"Restore","bwg_maximize":"Maximize","bwg_fullscreen":"Fullscreen","bwg_exit_fullscreen":"Exit Fullscreen","bwg_search_tag":"SEARCH...","bwg_tag_no_match":"No tags found","bwg_all_tags_selected":"All tags selected","bwg_tags_selected":"tags selected","play":"Play","pause":"Pause","is_pro":"1","bwg_play":"Play","bwg_pause":"Pause","bwg_hide_info":"Hide info","bwg_show_info":"Show info","bwg_hide_rating":"Hide rating","bwg_show_rating":"Show rating","ok":"Ok","cancel":"Cancel","select_all":"Select all","lazy_load":"0","lazy_loader":"http:\/\/www.lutherregister.news\/wp-content\/plugins\/photo-gallery\/images\/ajax_loader.png","front_ajax":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-content/plugins/photo-gallery/js/scripts.min.js'></script>
<script async type='text/javascript' src='https://stats.wp.com/s-202006.js'></script>
<link rel='https://api.w.org/' href='http://www.lutherregister.news/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.lutherregister.news/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.lutherregister.news/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='COLUMN: Legislative Update' href='http://www.lutherregister.news/2020/02/06/column-legislative-update/' />
<meta name="generator" content="WordPress 5.3.2" />
<meta name="generator" content="WooCommerce 3.8.1" />
<link rel='shortlink' href='https://wp.me/p6TWr2-53H' />
		 <script>
		   "use strict";
		   var amoTeamVars                      = {};
		   amoTeamVars.teamSC                   = [];
		   amoTeamVars.memberSC                 = [];
		   amoTeamVars[ 'panel-alt-scroll' ]    = 1;
		   amoTeamVars[ 'thumbs-clear-events' ] = 1;
		 </script><meta name="referrer" content="always"/>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-113572349-2"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-113572349-2');
</script>
<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=E37QbEqvLbeiytRStdw4xT3L";
	fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>
<div id="pp-banner"></div>
<meta name="generator" content="Jannah 3.2.0" />
<meta name="theme-color" content="#c90035" /><meta name="viewport" content="width=device-width, initial-scale=1.0" />	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<link rel="canonical" href="http://www.lutherregister.news/2020/02/07/election-2020-sharp-draws-primary-challenger/" />
<meta name="description" content="The state senator who represents Luther will face a primary opponent. Choctaw Republican Caleb Foshee announced his candidacy to unseat Senator Ron Sharp who has served since 2012. Senate District 17 represents a large swatch of Pottawatamie County, including populous Shawnee, as well as rural parts of Eastern Oklahoma County including Harrah, Choctaw, Nicoma Park, &hellip;" />
<meta property="og:title" content="ELECTION 2020: Sharp Draws Primary Challenger" />
<meta property="og:url" content="http://www.lutherregister.news/2020/02/07/election-2020-sharp-draws-primary-challenger/" />
<meta property="og:type" content="article" />
<meta property="article:published_time" content="2020-02-07T21:08:17-06:00" />
<meta property="og:description" content="The state senator who represents Luther will face a primary opponent. Choctaw Republican Caleb Foshee announced his candidacy to unseat Senator Ron Sharp who has served since 2012. Senate District 17 represents a large swatch of Pottawatamie County, including populous Shawnee, as well as rural parts of Eastern Oklahoma County including Harrah, Choctaw, Nicoma Park, &hellip;" />
<meta property="og:image" content="http://www.lutherregister.news/wp-content/uploads/2020/02/Caleb-Foshee-Family-Picture-e1581131120204.jpeg" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="737" />
<meta property="og:image:alt" content="ELECTION 2020: Sharp Draws Primary Challenger" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="ELECTION 2020: Sharp Draws Primary Challenger" />
<meta name="twitter:description" content="The state senator who represents Luther will face a primary opponent. Choctaw Republican Caleb Foshee announced his candidacy to unseat Senator Ron Sharp who has served since 2012. Senate District 17 represents a large swatch of Pottawatamie County, including populous Shawnee, as well as rural parts of Eastern Oklahoma County including Harrah, Choctaw, Nicoma Park, &hellip;" />
<meta name="twitter:image" content="http://www.lutherregister.news/wp-content/uploads/2020/02/Caleb-Foshee-Family-Picture-e1581131120204.jpeg" />

					<script>
						WebFontConfig ={
							google:{
								families: ['News+Cycle:regular:latin']
							}
						};
						(function(){
							var wf   = document.createElement('script');
							wf.src   = '//ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
							wf.type  = 'text/javascript';
							wf.async = 'true';
							var s = document.getElementsByTagName('script')[0];
							s.parentNode.insertBefore(wf, s);
						})();
					</script>
				<link rel="icon" href="http://www.lutherregister.news/wp-content/uploads/2018/07/cropped-27867775_1786011615026828_6759776463264911217_n-32x32.jpg" sizes="32x32" />
<link rel="icon" href="http://www.lutherregister.news/wp-content/uploads/2018/07/cropped-27867775_1786011615026828_6759776463264911217_n-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.lutherregister.news/wp-content/uploads/2018/07/cropped-27867775_1786011615026828_6759776463264911217_n-180x180.jpg" />
<meta name="msapplication-TileImage" content="http://www.lutherregister.news/wp-content/uploads/2018/07/cropped-27867775_1786011615026828_6759776463264911217_n-270x270.jpg" />
</head>

<body id="tie-body" class="post-template-default single single-post postid-19449 single-format-standard theme-jannah woocommerce-no-js et_bloom wrapper-has-shadow block-head-4 magazine2 is-thumb-overlay-disabled is-desktop is-header-layout-3 sidebar-right has-sidebar post-layout-1 narrow-title-narrow-media is-standard-format has-mobile-share wpbdp-with-button-styles">


<div class="background-overlay">

	<div id="tie-container" class="site tie-container">

		
		<div id="tie-wrapper">

			
<header id="theme-header" class="theme-header header-layout-3 main-nav-light main-nav-below main-nav-boxed top-nav-active top-nav-light top-nav-above has-shadow mobile-header-centered">
	
<nav id="top-nav" class="has-date-breaking-components top-nav header-nav has-breaking-news" aria-label="Secondary Navigation">
	<div class="container">
		<div class="topbar-wrapper">

			
					<div class="topbar-today-date">
						<span class="fa fa-clock-o" aria-hidden="true"></span>
						<strong class="inner-text">Friday, February 7 2020</strong>
					</div>
					
			<div class="tie-alignleft">
				
<div class="breaking controls-is-active">

	<span class="breaking-title">
		<span class="fa fa-bolt" aria-hidden="true"></span>
		<span class="breaking-title-text">Trending</span>
	</span>

	<ul id="breaking-news-in-header" class="breaking-news" data-type="reveal" data-arrows="true">

		
							<li class="news-item">
								<a href="http://www.lutherregister.news/2020/02/07/election-2020-sharp-draws-primary-challenger/" title="ELECTION 2020: Sharp Draws Primary Challenger">ELECTION 2020: Sharp Draws Primary Challenger</a>
							</li>

							
							<li class="news-item">
								<a href="http://www.lutherregister.news/2020/02/06/column-legislative-update/" title="COLUMN: Legislative Update">COLUMN: Legislative Update</a>
							</li>

							
							<li class="news-item">
								<a href="http://www.lutherregister.news/2020/02/04/register-by-february-7-to-vote-in-presidential-primary/" title="Register by February 7 to Vote in Presidential Primary">Register by February 7 to Vote in Presidential Primary</a>
							</li>

							
							<li class="news-item">
								<a href="http://www.lutherregister.news/2020/02/04/wanted-luther-code-enforcement-officer/" title="WANTED: Luther Code Enforcement Officer">WANTED: Luther Code Enforcement Officer</a>
							</li>

							
							<li class="news-item">
								<a href="http://www.lutherregister.news/2020/02/02/luther-school-board-candidate-forum/" title="Luther School Board Candidate Forum">Luther School Board Candidate Forum</a>
							</li>

							
							<li class="news-item">
								<a href="http://www.lutherregister.news/2020/02/02/luther-alum-part-of-award-winning-eoc-digital-media-team/" title="Luther Alum Part of Award-Winning EOC Digital Media Team">Luther Alum Part of Award-Winning EOC Digital Media Team</a>
							</li>

							
							<li class="news-item">
								<a href="http://www.lutherregister.news/2020/02/02/luther-hgtv-small-town-takeover-application-tools/" title="Luther HGTV Small Town Takeover Application Tools">Luther HGTV Small Town Takeover Application Tools</a>
							</li>

							
							<li class="news-item">
								<a href="http://www.lutherregister.news/2020/01/30/luther-police-bust-alleged-drug-ring/" title="Luther Police Bust Alleged Drug Ring">Luther Police Bust Alleged Drug Ring</a>
							</li>

							
							<li class="news-item">
								<a href="http://www.lutherregister.news/2020/01/29/obituary-remembering-dora-lyon/" title="OBITUARY: Remembering Dora Lyon">OBITUARY: Remembering Dora Lyon</a>
							</li>

							
							<li class="news-item">
								<a href="http://www.lutherregister.news/2020/01/28/invitation-help-luther-apply-for-hgtv-small-town-takeover/" title="INVITATION: Help Luther Apply for HGTV Small Town Takeover">INVITATION: Help Luther Apply for HGTV Small Town Takeover</a>
							</li>

							
	</ul>
</div><!-- #breaking /-->
			</div><!-- .tie-alignleft /-->

			<div class="tie-alignright">
				<ul class="components">	<li class="side-aside-nav-icon menu-item custom-menu-link">
		<a href="#">
			<span class="fa fa-navicon" aria-hidden="true"></span>
			<span class="screen-reader-text">Sidebar</span>
		</a>
	</li>
		<li class="popup-login-icon menu-item custom-menu-link">
	 	<a href="#" class="lgoin-btn tie-popup-trigger">
			<span class="fa fa-lock" aria-hidden="true"></span>
			<span class="screen-reader-text">Log In</span>
		</a>
	</li>
		<li class="random-post-icon menu-item custom-menu-link">
		<a href="/2020/02/07/election-2020-sharp-draws-primary-challenger/?random-post=1" class="random-post" title="Random Article" rel="nofollow">
			<span class="fa fa-random" aria-hidden="true"></span>
			<span class="screen-reader-text">Random Article</span>
		</a>
	</li>
	</ul><!-- Components -->			</div><!-- .tie-alignright /-->

		</div><!-- .topbar-wrapper /-->
	</div><!-- .container /-->
</nav><!-- #top-nav /-->

<div class="container">
	<div class="tie-row logo-row">

		
		<div class="logo-wrapper">
			<div class="tie-col-md-4 logo-container">
				
		<a href="#" id="mobile-menu-icon">
			<span class="nav-icon"></span>

				<span class="menu-text">Menu</span>		</a>
		
		<div id="logo" class="image-logo" >

			
			<a title="Luther Register News" href="http://www.lutherregister.news/">
				
					<img src="http://www.lutherregister.news/wp-content/uploads/2018/07/lr-logo-2.png" alt="Luther Register News" class="logo_normal" width="400" height="62" style="max-height:62px; width: auto;">
					<img src="http://www.lutherregister.news/wp-content/uploads/2018/07/lr-logo-2.png" alt="Luther Register News" class="logo_2x" width="400" height="62" style="max-height:62px; width: auto;">
							</a>

			
		</div><!-- #logo /-->

					</div><!-- .tie-col /-->
		</div><!-- .logo-wrapper /-->

		
	</div><!-- .tie-row /-->
</div><!-- .container /-->

<div class="main-nav-wrapper">
	<nav id="main-nav" data-skin="search-in-main-nav live-search-light" class="main-nav header-nav live-search-parent"  aria-label="Primary Navigation">
		<div class="container">

			<div class="main-menu-wrapper">

				
				<div id="menu-components-wrap">

					
					<div class="main-menu main-menu-wrap tie-alignleft">
						<div id="main-nav-menu" class="main-menu header-menu"><ul id="menu-primary" class="menu" role="menubar"><li id="menu-item-78" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-78"><a href="http://www.lutherregister.news/">Home</a></li>
<li id="menu-item-2131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2131"><a href="http://www.lutherregister.news/lutherlocal-business-directory/">Business Directory #lutherlocal</a></li>
<li id="menu-item-2147" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2147"><a href="http://www.lutherregister.news/support-news-for-our-town/">Advertise and Support</a></li>
<li id="menu-item-8447" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8447"><a href="http://www.lutherregister.news/the-team/">The Team</a></li>
<li id="menu-item-8377" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8377"><a href="http://www.lutherregister.news/pecan-festival/">Pecan Festival</a></li>
<li id="menu-item-8378" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8378"><a href="http://www.lutherregister.news/category/business/">Business</a></li>
<li id="menu-item-8379" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8379 tie-current-menu"><a href="http://www.lutherregister.news/category/community/">Community</a></li>
<li id="menu-item-8380" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8380"><a href="http://www.lutherregister.news/category/crime/">Crime</a></li>
<li id="menu-item-8381" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8381"><a href="http://www.lutherregister.news/category/education/">Education</a></li>
<li id="menu-item-8382" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8382"><a href="http://www.lutherregister.news/category/election-2018/">Election 2018</a></li>
<li id="menu-item-8383" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8383"><a href="http://www.lutherregister.news/category/fire/">Fire</a></li>
<li id="menu-item-8384" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8384"><a href="http://www.lutherregister.news/category/police/">Police</a></li>
<li id="menu-item-8385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8385"><a href="http://www.lutherregister.news/category/sports/">Sports</a></li>
<li id="menu-item-8386" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8386"><a href="http://www.lutherregister.news/category/town/">Town</a></li>
<li id="menu-item-8387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8387"><a href="http://www.lutherregister.news/category/turnpike/">Turnpike</a></li>
</ul></div>					</div><!-- .main-menu.tie-alignleft /-->

					<ul class="components">		<li class="search-bar menu-item custom-menu-link" aria-label="Search">
			<form method="get" id="search" action="http://www.lutherregister.news//">
				<input id="search-input" class="is-ajax-search" type="text" name="s" title="Search for" placeholder="Search for" />
				<button id="search-submit" type="submit"><span class="fa fa-search" aria-hidden="true"></span></button>
			</form>
		</li>
			<li class="side-aside-nav-icon menu-item custom-menu-link">
		<a href="#">
			<span class="fa fa-navicon" aria-hidden="true"></span>
			<span class="screen-reader-text">Sidebar</span>
		</a>
	</li>
		<li class="random-post-icon menu-item custom-menu-link">
		<a href="/2020/02/07/election-2020-sharp-draws-primary-challenger/?random-post=1" class="random-post" title="Random Article" rel="nofollow">
			<span class="fa fa-random" aria-hidden="true"></span>
			<span class="screen-reader-text">Random Article</span>
		</a>
	</li>
	 <li class="social-icons-item"><a class="social-link  rss-social-icon" title="RSS" rel="nofollow noopener" target="_blank" href="http://www.lutherregister.news/feed/"><span class="fa fa-rss"></span></a></li><li class="social-icons-item"><a class="social-link  instagram-social-icon" title="Instagram" rel="nofollow noopener" target="_blank" href="https://www.instagram.com/lutherregisternews/"><span class="fa fa-instagram"></span></a></li><li class="social-icons-item"><a class="social-link  twitter-social-icon" title="Twitter" rel="nofollow noopener" target="_blank" href="https://twitter.com/berryholler"><span class="fa fa-twitter"></span></a></li><li class="social-icons-item"><a class="social-link  facebook-social-icon" title="Facebook" rel="nofollow noopener" target="_blank" href="https://www.facebook.com/lutherregister.news/"><span class="fa fa-facebook"></span></a></li> </ul><!-- Components -->
				</div><!-- #menu-components-wrap /-->
			</div><!-- .main-menu-wrapper /-->
		</div><!-- .container /-->
	</nav><!-- #main-nav /-->
</div><!-- .main-nav-wrapper /-->

</header>


			<div id="content" class="site-content container">
				<div class="tie-row main-content-row">
		

<div class="main-content tie-col-md-8 tie-col-xs-12" role="main">

	
	<article id="the-post" class="container-wrapper post-content tie-standard">

		
<header class="entry-header-outer">

	
	<div class="entry-header">

		<span class="post-cat-wrap"><a class="post-cat tie-cat-38" href="http://www.lutherregister.news/category/community/">Community</a><a class="post-cat tie-cat-1639" href="http://www.lutherregister.news/category/election-2020/">Election 2020</a><a class="post-cat tie-cat-479" href="http://www.lutherregister.news/category/government/">Government</a></span>
		<h1 class="post-title entry-title">ELECTION 2020: Sharp Draws Primary Challenger</h1>

		<div class="post-meta">
				<span class="meta-author meta-item"><a href="http://www.lutherregister.news/author/dawnshelton/" class="author-name" title="dawnshelton"><span class="fa fa-user" aria-hidden="true"></span> dawnshelton</a>
				</span>
			
					<a href="http://@berryholler" class="author-twitter-link" target="_blank" rel="nofollow noopener">
						<span class="fa fa-twitter" aria-hidden="true"></span>
						<span class="screen-reader-text"></span>
					</a>
				
					<a href="/cdn-cgi/l/email-protection#94f0f5e3fae7fcf1f8e0fbfad4f8e1e0fcf1e6e6f1f3fde7e0f1e6bafaf1e3e7" class="author-email-link" target="_blank" rel="nofollow noopener">
						<span class="fa fa-envelope" aria-hidden="true"></span>
						<span class="screen-reader-text"></span>
					</a>
				<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>20 seconds ago</span></span><div class="tie-alignright"><span class="meta-comment meta-item"><a href="http://www.lutherregister.news/2020/02/07/election-2020-sharp-draws-primary-challenger/#respond"><span class="fa fa-comments" aria-hidden="true"></span> 0</a></span><span class="meta-views meta-item "><span class="tie-icon-fire" aria-hidden="true"></span> 0 </span><span class="meta-reading-time meta-item"><span class="fa fa-bookmark" aria-hidden="true"></span> 1 minute read</span> </div><div class="clearfix"></div></div><!-- .post-meta -->	</div><!-- .entry-header /-->

	
	
</header><!-- .entry-header-outer /-->

<div  class="featured-area"><div class="featured-area-inner"><figure class="single-featured-image"><img width="550" height="405" src="http://www.lutherregister.news/wp-content/uploads/2020/02/Caleb-Foshee-Family-Picture-e1581131120204.jpeg" class="attachment-jannah-image-post size-jannah-image-post wp-post-image" alt="" />
						<figcaption class="single-caption-text">
							<span class="fa fa-camera" aria-hidden="true"></span> Caleb Foshee, senate candidate. Photo provided.
						</figcaption>
					</figure></div></div>
		<div class="entry-content entry clearfix">

			<div class="stream-item stream-item-above-post-content"><broadstreet-zone zone-id="68488"></broadstreet-zone>
</div>
			<div dir="ltr">

<div title="Page 1">

<p>The state senator who represents Luther will face a primary opponent. Choctaw Republican Caleb Foshee announced his candidacy to unseat Senator Ron Sharp who has served since 2012.</p>

<p>Senate District 17 represents a large swatch of Pottawatamie County, including populous Shawnee, as well as rural parts of Eastern Oklahoma County including Harrah, Choctaw, Nicoma Park, Jones, as well as Luther.</p><div class="stream-item stream-item-in-post stream-item-inline-post aligncenter"></div>

<div style="margin:5px auto; margin-bottom: 15px;"><broadstreet-zone zone-id="68495" keywords="not_home_page,not_landing_page,is_article_page,community,election-2020,government,election-2020-sharp-draws-primary-challenger,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div>

<p>“I am pleased and honored to announce my candidacy to serve Senate District 17. Eastern Oklahoma and Northern Pottawatomie Counties deserve someone who will fight for them on all fronts, including student centered solutions in education and less government regulations in order to spur economic development.”</p>

<figure id="attachment_19451" aria-describedby="caption-attachment-19451" style="width: 600px" class="wp-caption aligncenter"><img class="wp-image-19451 size-full" src="http://www.lutherregister.news/wp-content/uploads/2020/02/STATE-SEN-17.jpg" alt="" width="600" height="463" srcset="http://www.lutherregister.news/wp-content/uploads/2020/02/STATE-SEN-17.jpg 600w, http://www.lutherregister.news/wp-content/uploads/2020/02/STATE-SEN-17-300x232.jpg 300w, http://www.lutherregister.news/wp-content/uploads/2020/02/STATE-SEN-17-150x116.jpg 150w" sizes="(max-width: 600px) 100vw, 600px" /><figcaption id="caption-attachment-19451" class="wp-caption-text">Oklahoma State Senate District 17.</figcaption></figure>

<p>Caleb Foshee, chief operating officer at a commercial/industrial electrical contracting company was previously a Command HR Director for the US Air Force and a Regional HR Director for the Indian Health Service. “I’ve dealt with the clutter and bureaucracy of government service and in my current job I feel the impact to businesses and their employees due to government regulations and reporting. We need to take the handcuffs off of the largest job creators in our state &#8211; small business owners.”</p>

<p>“If elected, my first priority will be to take a holistic approach in representing the district. I do not intend to be a single-issue legislator who becomes known for being entangled in one issue, at the expense of my constituents being served on all issues that personally and district-wide affect them.”</p>

<div style="margin:5px auto; margin-bottom: 15px;"><broadstreet-zone zone-id="68495" keywords="not_home_page,not_landing_page,is_article_page,community,election-2020,government,election-2020-sharp-draws-primary-challenger,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div>

<p>“Another pillar of my campaign is that every life is precious, from conception to natural death. This includes both babies and elders, but also includes people like single mothers, the poor, and veterans who might be struggling with mental health issues. Every person’s dignity must be protected.”</p>

<p>“We need a new generation of Patriots who will take a stand to protect our individual rights. There is currently legislation in the Capitol that seeks to repeal Constitutional Carry and otherwise limit our right to bear arms. This will only affect law abiding citizens &#8211; not those who perpetrate gun violence.”</p>

<p>Foshee grew up in Eastern Oklahoma County, graduating from Jones High School in 1998 and Oklahoma State University in 2003. He is also a proud member of the Choctaw Nation of Oklahoma. Caleb, his wife of 16 years, Britton, and their four children reside in Choctaw.</p>

</div>

</div>

<div class="yj6qo"></div>

<div class="adL"></div>

</p>
			<div class="stream-item stream-item-below-post-content"><broadstreet-zone zone-id="68489"></broadstreet-zone>
</div><div class="post-bottom-meta"><div class="post-bottom-meta-title"><span class="fa fa-tags" aria-hidden="true"></span> Tags</div><span class="tagcloud"><a href="http://www.lutherregister.news/tag/caleb-foshee/" rel="tag">Caleb Foshee</a> <a href="http://www.lutherregister.news/tag/election-2020/" rel="tag">election 2020</a> <a href="http://www.lutherregister.news/tag/oklahoma-state-senate/" rel="tag">Oklahoma State Senate</a> <a href="http://www.lutherregister.news/tag/sen-ron-sharp/" rel="tag">Sen. Ron Sharp</a></span></div>
		</div><!-- .entry-content /-->

		<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2020-02-07T21:08:17-06:00","datePublished":"2020-02-07T21:08:17-06:00","dateModified":"2020-02-07T21:08:17-06:00","headline":"ELECTION 2020: Sharp Draws Primary Challenger","name":"ELECTION 2020: Sharp Draws Primary Challenger","keywords":"Caleb Foshee,election 2020,Oklahoma State Senate,Sen. Ron Sharp","url":"http:\/\/www.lutherregister.news\/2020\/02\/07\/election-2020-sharp-draws-primary-challenger\/","description":"The state senator who represents Luther will face a primary opponent. Choctaw Republican Caleb Foshee announced his candidacy to unseat Senator Ron Sharp who has served since 2012. Senate District 17","copyrightYear":"2020","articleSection":"Community,Election 2020,Government","articleBody":"\r\n\r\n\r\nThe state senator who represents Luther will face a primary opponent. Choctaw Republican Caleb Foshee announced his candidacy to unseat Senator Ron Sharp who has served since 2012.\r\n\r\nSenate District 17 represents a large swatch of Pottawatamie County, including populous Shawnee, as well as rural parts of Eastern Oklahoma County including Harrah, Choctaw, Nicoma Park, Jones, as well as Luther.\r\n\r\n\u201cI am pleased and honored to announce my candidacy to serve Senate District 17. Eastern Oklahoma and Northern Pottawatomie Counties deserve someone who will fight for them on all fronts, including student centered solutions in education and less government regulations in order to spur economic development.\u201d\r\n\r\n\r\n\r\nCaleb Foshee, chief operating officer at a commercial\/industrial electrical contracting company was previously a Command HR Director for the US Air Force and a Regional HR Director for the Indian Health Service. \u201cI\u2019ve dealt with the clutter and bureaucracy of government service and in my current job I feel the impact to businesses and their employees due to government regulations and reporting. We need to take the handcuffs off of the largest job creators in our state - small business owners.\u201d\r\n\r\n\u201cIf elected, my first priority will be to take a holistic approach in representing the district. I do not intend to be a single-issue legislator who becomes known for being entangled in one issue, at the expense of my constituents being served on all issues that personally and district-wide affect them.\u201d\r\n\r\n\u201cAnother pillar of my campaign is that every life is precious, from conception to natural death. This includes both babies and elders, but also includes people like single mothers, the poor, and veterans who might be struggling with mental health issues. Every person\u2019s dignity must be protected.\u201d\r\n\r\n\u201cWe need a new generation of Patriots who will take a stand to protect our individual rights. There is currently legislation in the Capitol that seeks to repeal Constitutional Carry and otherwise limit our right to bear arms. This will only affect law abiding citizens - not those who perpetrate gun violence.\u201d\r\n\r\nFoshee grew up in Eastern Oklahoma County, graduating from Jones High School in 1998 and Oklahoma State University in 2003. He is also a proud member of the Choctaw Nation of Oklahoma. Caleb, his wife of 16 years, Britton, and their four children reside in Choctaw.\r\n\r\n&nbsp;\r\n\r\n\r\n\r\n\r\n","publisher":{"@id":"#Publisher","@type":"Organization","name":"Luther Register News","logo":{"@type":"ImageObject","url":"http:\/\/www.lutherregister.news\/wp-content\/uploads\/2018\/07\/lr-logo-2.png"},"sameAs":["https:\/\/www.facebook.com\/lutherregister.news\/","https:\/\/twitter.com\/berryholler","https:\/\/www.instagram.com\/lutherregisternews\/"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.lutherregister.news\/2020\/02\/07\/election-2020-sharp-draws-primary-challenger\/"},"author":{"@type":"Person","name":"dawnshelton","url":"http:\/\/www.lutherregister.news\/author\/dawnshelton\/"},"image":{"@type":"ImageObject","url":"http:\/\/www.lutherregister.news\/wp-content\/uploads\/2020\/02\/Caleb-Foshee-Family-Picture-e1581131120204.jpeg","width":1000,"height":737}}</script>
		<div class="post-footer post-footer-on-bottom">
			<div class="share-links ">
				<a href="https://www.facebook.com/sharer.php?u=https://wp.me/p6TWr2-53H" rel="external noopener" target="_blank" class="facebook-share-btn large-share-button"><span class="fa fa-facebook"></span> <span class="social-text">Facebook</span></a><a href="https://twitter.com/intent/tweet?text=ELECTION+2020%3A+Sharp+Draws+Primary+Challenger&#038;url=https://wp.me/p6TWr2-53H&#038;via=@berryholler" rel="external noopener" target="_blank" class="twitter-share-btn large-share-button"><span class="fa fa-twitter"></span> <span class="social-text">Twitter</span></a><a href="https://plusone.google.com/_/+1/confirm?hl=en&#038;url=https://wp.me/p6TWr2-53H&#038;name=ELECTION+2020%3A+Sharp+Draws+Primary+Challenger" rel="external noopener" target="_blank" class="google-share-btn"><span class="fa fa-google"></span> <span class="screen-reader-text">Google+</span></a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://wp.me/p6TWr2-53H&#038;title=ELECTION+2020%3A+Sharp+Draws+Primary+Challenger" rel="external noopener" target="_blank" class="linkedin-share-btn"><span class="fa fa-linkedin"></span> <span class="screen-reader-text">LinkedIn</span></a><a href="https://www.tumblr.com/share/link?url=https://wp.me/p6TWr2-53H&#038;name=ELECTION+2020%3A+Sharp+Draws+Primary+Challenger" rel="external noopener" target="_blank" class="tumblr-share-btn"><span class="fa fa-tumblr"></span> <span class="screen-reader-text">Tumblr</span></a><a href="https://pinterest.com/pin/create/button/?url=https://wp.me/p6TWr2-53H&#038;description=ELECTION+2020%3A+Sharp+Draws+Primary+Challenger&#038;media=http://www.lutherregister.news/wp-content/uploads/2020/02/Caleb-Foshee-Family-Picture-e1581131120204.jpeg" rel="external noopener" target="_blank" class="pinterest-share-btn"><span class="fa fa-pinterest"></span> <span class="screen-reader-text">Pinterest</span></a><a href="https://reddit.com/submit?url=https://wp.me/p6TWr2-53H&#038;title=ELECTION+2020%3A+Sharp+Draws+Primary+Challenger" rel="external noopener" target="_blank" class="reddit-share-btn"><span class="fa fa-reddit"></span> <span class="screen-reader-text">Reddit</span></a><a href="/cdn-cgi/l/email-protection#66591513040c0305125b232a2325322f29284d545654564355274d350e0714164d22140711154d36140f0b07141f4d250e070a0a0308010314404556555e5d0409021f5b0e121216155c49491116480b03491650323114544b53552e" rel="external noopener" target="_blank" class="email-share-btn"><span class="fa fa-envelope"></span> <span class="screen-reader-text">Share via Email</span></a><a href="#" rel="external noopener" target="_blank" class="print-share-btn"><span class="fa fa-print"></span> <span class="screen-reader-text">Print</span></a>			</div><!-- .share-links /-->
		</div><!-- .post-footer-on-top /-->

		
	</article><!-- #the-post /-->

	<div class="stream-item stream-item-below-post"><broadstreet-zone zone-id="68490"></broadstreet-zone>
</div>
	<div class="post-components">

		
	<div id="read-next-block" class="container-wrapper read-next-slider-50">
		<h2 class="read-next-block-title">Read Next</h2>
		
			<section id="tie-read-next" class="slider-area mag-box">

				
					<div id="tie-main-slider-50-read-next" class="tie-main-slider main-slider wide-slider-with-navfor-wrapper wide-slider-wrapper slider-vertical-navigation tie-slick-slider-wrapper" data-slider-id="50"  data-autoplay="true" data-speed="3000">

						
						<div class="main-slider-inner">

							
								<div class="container slider-main-container">
									<div class="tie-slick-slider">
										<ul class="tie-slider-nav"></ul>

										<div style="background-image: url(http://www.lutherregister.news/wp-content/uploads/2020/02/LEGISLATIVE-UDPATE.png)" class="slide slide-id-19385 tie-slide-1 tie-standard">
					<a href="http://www.lutherregister.news/2020/02/06/column-legislative-update/" class="all-over-thumb-link"><span class="screen-reader-text">COLUMN: Legislative Update</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-38" href="http://www.lutherregister.news/category/community/">Community</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>1 day ago</span></span></div>
				<h2 class="thumb-title"><a href="http://www.lutherregister.news/2020/02/06/column-legislative-update/" title="COLUMN: Legislative Update">COLUMN: Legislative Update</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(http://www.lutherregister.news/wp-content/uploads/2019/12/vote.png)" class="slide slide-id-19293 tie-slide-2 tie-standard">
					<a href="http://www.lutherregister.news/2020/02/04/register-by-february-7-to-vote-in-presidential-primary/" class="all-over-thumb-link"><span class="screen-reader-text">Register by February 7 to Vote in Presidential Primary</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-1639" href="http://www.lutherregister.news/category/election-2020/">Election 2020</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>3 days ago</span></span></div>
				<h2 class="thumb-title"><a href="http://www.lutherregister.news/2020/02/04/register-by-february-7-to-vote-in-presidential-primary/" title="Register by February 7 to Vote in Presidential Primary">Register by February 7 to Vote in Presidential Primary</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(http://www.lutherregister.news/wp-content/uploads/2020/02/NOW-HIRING-2.png)" class="slide slide-id-19288 tie-slide-3 tie-standard">
					<a href="http://www.lutherregister.news/2020/02/04/wanted-luther-code-enforcement-officer/" class="all-over-thumb-link"><span class="screen-reader-text">WANTED: Luther Code Enforcement Officer</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-38" href="http://www.lutherregister.news/category/community/">Community</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>3 days ago</span></span></div>
				<h2 class="thumb-title"><a href="http://www.lutherregister.news/2020/02/04/wanted-luther-code-enforcement-officer/" title="WANTED: Luther Code Enforcement Officer">WANTED: Luther Code Enforcement Officer</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(http://www.lutherregister.news/wp-content/uploads/2020/02/FORUM.png)" class="slide slide-id-19193 tie-slide-4 tie-standard">
					<a href="http://www.lutherregister.news/2020/02/02/luther-school-board-candidate-forum/" class="all-over-thumb-link"><span class="screen-reader-text">Luther School Board Candidate Forum</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-38" href="http://www.lutherregister.news/category/community/">Community</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>5 days ago</span></span></div>
				<h2 class="thumb-title"><a href="http://www.lutherregister.news/2020/02/02/luther-school-board-candidate-forum/" title="Luther School Board Candidate Forum">Luther School Board Candidate Forum</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(http://www.lutherregister.news/wp-content/uploads/2020/02/EOC-DIGITAL-1.jpg)" class="slide slide-id-19179 tie-slide-5 tie-standard">
					<a href="http://www.lutherregister.news/2020/02/02/luther-alum-part-of-award-winning-eoc-digital-media-team/" class="all-over-thumb-link"><span class="screen-reader-text">Luther Alum Part of Award-Winning EOC Digital Media Team</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-39" href="http://www.lutherregister.news/category/education/">Education</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>5 days ago</span></span></div>
				<h2 class="thumb-title"><a href="http://www.lutherregister.news/2020/02/02/luther-alum-part-of-award-winning-eoc-digital-media-team/" title="Luther Alum Part of Award-Winning EOC Digital Media Team">Luther Alum Part of Award-Winning EOC Digital Media Team</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(http://www.lutherregister.news/wp-content/uploads/2020/02/TJA1.jpg)" class="slide slide-id-19141 tie-slide-6 is-trending tie-standard">
					<a href="http://www.lutherregister.news/2020/02/02/luther-hgtv-small-town-takeover-application-tools/" class="all-over-thumb-link"><span class="screen-reader-text">Luther HGTV Small Town Takeover Application Tools</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-38" href="http://www.lutherregister.news/category/community/">Community</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="trending-post fa fa-bolt " aria-hidden="true"></span><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>5 days ago</span></span></div>
				<h2 class="thumb-title"><a href="http://www.lutherregister.news/2020/02/02/luther-hgtv-small-town-takeover-application-tools/" title="Luther HGTV Small Town Takeover Application Tools">Luther HGTV Small Town Takeover Application Tools</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(http://www.lutherregister.news/wp-content/uploads/2020/01/DORA-LYON.png)" class="slide slide-id-18941 tie-slide-1 tie-standard">
					<a href="http://www.lutherregister.news/2020/01/29/obituary-remembering-dora-lyon/" class="all-over-thumb-link"><span class="screen-reader-text">OBITUARY: Remembering Dora Lyon</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-38" href="http://www.lutherregister.news/category/community/">Community</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>1 week ago</span></span></div>
				<h2 class="thumb-title"><a href="http://www.lutherregister.news/2020/01/29/obituary-remembering-dora-lyon/" title="OBITUARY: Remembering Dora Lyon">OBITUARY: Remembering Dora Lyon</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(http://www.lutherregister.news/wp-content/uploads/2020/01/IMG_7409.jpg)" class="slide slide-id-18877 tie-slide-2 tie-standard">
					<a href="http://www.lutherregister.news/2020/01/28/invitation-help-luther-apply-for-hgtv-small-town-takeover/" class="all-over-thumb-link"><span class="screen-reader-text">INVITATION: Help Luther Apply for HGTV Small Town Takeover</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-38" href="http://www.lutherregister.news/category/community/">Community</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>1 week ago</span></span></div>
				<h2 class="thumb-title"><a href="http://www.lutherregister.news/2020/01/28/invitation-help-luther-apply-for-hgtv-small-town-takeover/" title="INVITATION: Help Luther Apply for HGTV Small Town Takeover">INVITATION: Help Luther Apply for HGTV Small Town Takeover</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(http://www.lutherregister.news/wp-content/uploads/2020/01/VOTE-SKOO-BOARD.png)" class="slide slide-id-18767 tie-slide-3 tie-standard">
					<a href="http://www.lutherregister.news/2020/01/26/school-board-candidate-meet-kevin-boydston/" class="all-over-thumb-link"><span class="screen-reader-text">SCHOOL BOARD CANDIDATE: Meet Kevin Boydston</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-38" href="http://www.lutherregister.news/category/community/">Community</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>2 weeks ago</span></span></div>
				<h2 class="thumb-title"><a href="http://www.lutherregister.news/2020/01/26/school-board-candidate-meet-kevin-boydston/" title="SCHOOL BOARD CANDIDATE: Meet Kevin Boydston">SCHOOL BOARD CANDIDATE: Meet Kevin Boydston</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			<div style="background-image: url(http://www.lutherregister.news/wp-content/uploads/2020/01/VOTE-SKOO-BOARD.png)" class="slide slide-id-18760 tie-slide-4 tie-standard">
					<a href="http://www.lutherregister.news/2020/01/26/school-board-candidate-meet-clint-rayburn/" class="all-over-thumb-link"><span class="screen-reader-text">SCHOOL BOARD CANDIDATE: Meet Clint Rayburn</span></a>
					<div class="thumb-overlay"><div class="container"><h5 class="post-cat-wrap"><a class="post-cat tie-cat-38" href="http://www.lutherregister.news/category/community/">Community</a></h5><div class="thumb-content"><div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>2 weeks ago</span></span></div>
				<h2 class="thumb-title"><a href="http://www.lutherregister.news/2020/01/26/school-board-candidate-meet-clint-rayburn/" title="SCHOOL BOARD CANDIDATE: Meet Clint Rayburn">SCHOOL BOARD CANDIDATE: Meet Clint Rayburn</a></h2>
			</div> <!-- .thumb-content /--></div><!-- .container -->
					</div><!-- .thumb-overlay /-->
				</div><!-- .slide || .grid-item /-->
			
									</div><!-- .tie-slick-slider /-->
								</div><!-- .slider-main-container /-->

							
						</div><!-- .main-slider-inner  /-->
					</div><!-- .main-slider /-->

					
						<div class="wide-slider-nav-wrapper vertical-slider-nav ">
							<ul class="tie-slider-nav"></ul>

							<div class="container">
								<div class="tie-row">
									<div class="tie-col-md-12">
										<div class="tie-slick-slider">

											
													<div class="slide tie-slide-5">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>1 day ago</span></span></div>
															<h3 class="thumb-title">COLUMN: Legislative Update</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-6">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>3 days ago</span></span></div>
															<h3 class="thumb-title">Register by February 7 to Vote in Presidential Primary</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-1">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>3 days ago</span></span></div>
															<h3 class="thumb-title">WANTED: Luther Code Enforcement Officer</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-2">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>5 days ago</span></span></div>
															<h3 class="thumb-title">Luther School Board Candidate Forum</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-3">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>5 days ago</span></span></div>
															<h3 class="thumb-title">Luther Alum Part of Award-Winning EOC Digital Media Team</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-4">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="trending-post fa fa-bolt " aria-hidden="true"></span><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>5 days ago</span></span></div>
															<h3 class="thumb-title">Luther HGTV Small Town Takeover Application Tools</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-5">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>1 week ago</span></span></div>
															<h3 class="thumb-title">OBITUARY: Remembering Dora Lyon</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-6">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>1 week ago</span></span></div>
															<h3 class="thumb-title">INVITATION: Help Luther Apply for HGTV Small Town Takeover</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-1">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>2 weeks ago</span></span></div>
															<h3 class="thumb-title">SCHOOL BOARD CANDIDATE: Meet Kevin Boydston</h3>

														</div>
													</div><!-- slide /-->

													
													<div class="slide tie-slide-2">
														<div class="slide-overlay">

															<div class="thumb-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>2 weeks ago</span></span></div>
															<h3 class="thumb-title">SCHOOL BOARD CANDIDATE: Meet Clint Rayburn</h3>

														</div>
													</div><!-- slide /-->

													
										</div><!-- .wide_slider_nav /-->
									</div><!-- .tie-col /-->
								</div><!-- .tie-row /-->
							</div><!-- .container /-->
						</div><!-- #wide-slider-nav-wrapper /-->
						
		</section><!-- .slider-area -->

				</div><!-- #read-next-block -->

	
		<div class="about-author container-wrapper">

								<div class="author-avatar">
						<a href="http://www.lutherregister.news/author/dawnshelton/">
							<img src="http://www.lutherregister.news/wp-content/uploads/userphoto/5.png" alt="dawnshelton" width="150" height="150" class="photo" />						</a>
					</div><!-- .author-avatar /-->
					
			<div class="author-info">
				<h3 class="author-name"><a href="http://www.lutherregister.news/author/dawnshelton/">dawnshelton</a></h3>

				<div class="author-bio">
					Every town needs news. The Luther Register is part of a growing movement of local, independent, online news that shines an informative light in our communities. Readers can <a href="http://www.lutherregister.news/support-news-for-our-town/">support</a> the work through one-time or monthly <a href="http://www.lutherregister.news/donate/">donations</a>, <a href="http://www.lutherregister.news/support-news-for-our-town/">advertising</a> to directly reach an audience, sponsorships and also through participating in our events, such as the annual <a href="http://www.lutherregister.news/pecan-festival/">Luther Pecan Festival</a> held in November. #lutherlocal #localnews				</div><!-- .author-bio /-->

				<ul class="social-icons">
								<li class="social-icons-item">
									<a href="https://www.facebook.com/lutherregister.news/?eid=ARDU2aK8fuFoEBFTwBo-LP-Is1ODg316rmECN5UHErGXRy2wJZp9XhcVBbHlrX5zcVkSSNst3L35LWjz" rel="external noopener" target="_blank" class="social-link facebook-social-icon">
									<span class="fa fa-facebook" aria-hidden="true"></span>
									<span class="screen-reader-text">Facebook</span>
									</a>
								</li>
							
								<li class="social-icons-item">
									<a href="http://@berryholler" rel="external noopener" target="_blank" class="social-link twitter-social-icon">
									<span class="fa fa-twitter" aria-hidden="true"></span>
									<span class="screen-reader-text">Twitter</span>
									</a>
								</li>
							
								<li class="social-icons-item">
									<a href="http://Dawn%20Shelton" rel="external noopener" target="_blank" class="social-link linkedin-social-icon">
									<span class="fa fa-linkedin" aria-hidden="true"></span>
									<span class="screen-reader-text">LinkedIn</span>
									</a>
								</li>
							
								<li class="social-icons-item">
									<a href="http://Luther%20Register%20News" rel="external noopener" target="_blank" class="social-link instagram-social-icon">
									<span class="fa fa-instagram" aria-hidden="true"></span>
									<span class="screen-reader-text">Instagram</span>
									</a>
								</li>
							</ul>			</div><!-- .author-info /-->
			<div class="clearfix"></div>
		</div><!-- .about-author /-->
		
	

				<div id="related-posts" class="container-wrapper has-extra-post">

					<div class="mag-box-title the-global-title">
						<h3>Related Articles</h3>
					</div>

					<div class="related-posts-list">

					
							<div class="related-item">

								
			<a href="http://www.lutherregister.news/2018/05/04/deep-fork-drowning/" title="Deep Fork Tragedy" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="390" height="220" src="http://www.lutherregister.news/wp-content/uploads/2018/05/crop-390x220.jpg" class="attachment-jannah-image-large size-jannah-image-large wp-post-image" alt="" /></a>
								<h3 class="post-title"><a href="http://www.lutherregister.news/2018/05/04/deep-fork-drowning/" title="Deep Fork Tragedy">Deep Fork Tragedy</a></h3>

								<div class="post-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>May 4, 2018</span></span><div class="clearfix"></div></div><!-- .post-meta -->							</div><!-- .related-item /-->

						
							<div class="related-item">

								
								<h3 class="post-title"><a href="http://www.lutherregister.news/2017/02/27/zoo-seeks-giraffe-artists/" title="Zoo seeks giraffe artists">Zoo seeks giraffe artists</a></h3>

								<div class="post-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>February 27, 2017</span></span><div class="clearfix"></div></div><!-- .post-meta -->							</div><!-- .related-item /-->

						
							<div class="related-item tie-standard">

								
			<a href="http://www.lutherregister.news/2019/03/08/lady-lions-end-season-in-the-top-eight/" title="Lady Lions End Season in the Top Eight" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="390" height="220" src="http://www.lutherregister.news/wp-content/uploads/2019/03/246A0407-390x220.jpg" class="attachment-jannah-image-large size-jannah-image-large wp-post-image" alt="" /></a>
								<h3 class="post-title"><a href="http://www.lutherregister.news/2019/03/08/lady-lions-end-season-in-the-top-eight/" title="Lady Lions End Season in the Top Eight">Lady Lions End Season in the Top Eight</a></h3>

								<div class="post-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>March 8, 2019</span></span><div class="clearfix"></div></div><!-- .post-meta -->							</div><!-- .related-item /-->

						
							<div class="related-item">

								
								<h3 class="post-title"><a href="http://www.lutherregister.news/2017/04/19/reclaimed-wood-sale/" title="Reclaimed Wood Sale">Reclaimed Wood Sale</a></h3>

								<div class="post-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>April 19, 2017</span></span><div class="clearfix"></div></div><!-- .post-meta -->							</div><!-- .related-item /-->

						
					</div><!-- .related-posts-list /-->
				</div><!-- #related-posts /-->

				<div id="comments" class="comments-area">

		

		<div id="add-comment-block" class="container-wrapper">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title the-global-title has-block-head-4">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/02/07/election-2020-sharp-draws-primary-challenger/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://www.lutherregister.news/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='19449' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="9cc95729fc" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="11"/></p></form>	</div><!-- #respond -->
	</div><!-- #add-comment-block /-->
	</div><!-- .comments-area -->


	</div><!-- .post-components /-->

	
</div><!-- .main-content -->


	<div id="check-also-box" class="container-wrapper check-also-right">

		<div class="widget-title the-global-title has-block-head-4">
			<h4>Check Also</h4>

			<a href="#" id="check-also-close" class="remove">
				<span class="screen-reader-text">Close</span>
			</a>
		</div>

		<div class="widget posts-list-big-first has-first-big-post">
			<ul class="posts-list-items">

			
<li class="widget-post-list">

	
	<div class="post-widget-body no-small-thumbs">
		<h3 class="post-title"><a href="http://www.lutherregister.news/2016/02/01/ota-public-hearing-set/" title="OTA Public Hearing Set">OTA Public Hearing Set</a></h3>

		<div class="post-meta">
			<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>February 1, 2016</span></span>		</div>
	</div>
</li>

			</ul><!-- .related-posts-list /-->
		</div>
	</div><!-- #related-posts /-->

	
	<aside class="sidebar tie-col-md-4 tie-col-xs-12 normal-side is-sticky" aria-label="Primary Sidebar">
		<div class="theiaStickySidebar">
			<div id="bs_zones-2" class="container-wrapper widget bs_zones"><div class="widget-title the-global-title has-block-head-4"><h4>Support the Luther Register<span class="widget-title-icon fa"></span></h4></div><div><broadstreet-zone zone-id="68475" keywords="not_home_page,not_landing_page,is_article_page,community,election-2020,government,election-2020-sharp-draws-primary-challenger,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><div class="clearfix"></div></div><!-- .widget /--><div id="bs_zones-3" class="container-wrapper widget bs_zones"><div><broadstreet-zone zone-id="68476" keywords="not_home_page,not_landing_page,is_article_page,community,election-2020,government,election-2020-sharp-draws-primary-challenger,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><div class="clearfix"></div></div><!-- .widget /--><div id="text-html-widget-2" class="container-wrapper widget text-html"><div class="widget-title the-global-title has-block-head-4"><h4>The Luther Register<span class="widget-title-icon fa"></span></h4></div><div >PO Box 311 
Luther, OK 73054
<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="fb9f9a8c9588939e978f9495bb978e8f939e89899e9c92888f9e89d5959e8c88">[email&#160;protected]</a></div><div class="clearfix"></div></div><!-- .widget /--><div id="tie-newsletter-3" class="container-wrapper widget subscribe-widget"><div class="widget-title the-global-title has-block-head-4"><h4>Newsletter<span class="widget-title-icon fa"></span></h4></div>
			<div class="widget-inner-wrap">

										<span class="fa fa-envelope newsletter-icon" aria-hidden="true"></span>
												<div class="subscribe-widget-content">
							<h3>Subscribe to our mailing list to get the new updates!</h3>						</div>
												<div id="mc_embed_signup-tie-newsletter-3">
							<form action="https://news.us15.list-manage.com/subscribe/post?u=71e8fa22d398857d731048211&amp;id=b4a5b22b0c" method="post" id="mc-embedded-subscribe-form-tie-newsletter-3" name="mc-embedded-subscribe-form" class="subscribe-form validate" target="_blank" novalidate>
									<div class="mc-field-group">
										<label class="screen-reader-text" for="mce-EMAIL-tie-newsletter-3">Enter your Email address</label>
										<input type="email" value="" id="mce-EMAIL-tie-newsletter-3" placeholder="Enter your Email address" name="EMAIL" class="subscribe-input required email">
									</div>
									<input type="submit" value="Subscribe" name="subscribe" class="button subscribe-submit">
							</form>
						</div>
						
			</div><!-- .widget-inner-wrap /-->

			<div class="clearfix"></div></div><!-- .widget /--><div id="bs_zones-4" class="container-wrapper widget bs_zones"><div><broadstreet-zone zone-id="68477" keywords="not_home_page,not_landing_page,is_article_page,community,election-2020,government,election-2020-sharp-draws-primary-challenger,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><div class="clearfix"></div></div><!-- .widget /--><div id="archives-3" class="container-wrapper widget widget_archive"><div class="widget-title the-global-title has-block-head-4"><h4>Stories<span class="widget-title-icon fa"></span></h4></div>		<ul>
				<li><a href='http://www.lutherregister.news/2020/02/'>February 2020</a>&nbsp;(7)</li>
	<li><a href='http://www.lutherregister.news/2020/01/'>January 2020</a>&nbsp;(15)</li>
	<li><a href='http://www.lutherregister.news/2019/12/'>December 2019</a>&nbsp;(11)</li>
	<li><a href='http://www.lutherregister.news/2019/11/'>November 2019</a>&nbsp;(13)</li>
	<li><a href='http://www.lutherregister.news/2019/10/'>October 2019</a>&nbsp;(18)</li>
	<li><a href='http://www.lutherregister.news/2019/09/'>September 2019</a>&nbsp;(21)</li>
	<li><a href='http://www.lutherregister.news/2019/08/'>August 2019</a>&nbsp;(10)</li>
	<li><a href='http://www.lutherregister.news/2019/07/'>July 2019</a>&nbsp;(16)</li>
	<li><a href='http://www.lutherregister.news/2019/06/'>June 2019</a>&nbsp;(12)</li>
	<li><a href='http://www.lutherregister.news/2019/05/'>May 2019</a>&nbsp;(19)</li>
	<li><a href='http://www.lutherregister.news/2019/04/'>April 2019</a>&nbsp;(19)</li>
	<li><a href='http://www.lutherregister.news/2019/03/'>March 2019</a>&nbsp;(20)</li>
	<li><a href='http://www.lutherregister.news/2019/02/'>February 2019</a>&nbsp;(25)</li>
	<li><a href='http://www.lutherregister.news/2019/01/'>January 2019</a>&nbsp;(29)</li>
	<li><a href='http://www.lutherregister.news/2018/12/'>December 2018</a>&nbsp;(33)</li>
	<li><a href='http://www.lutherregister.news/2018/11/'>November 2018</a>&nbsp;(31)</li>
	<li><a href='http://www.lutherregister.news/2018/10/'>October 2018</a>&nbsp;(51)</li>
	<li><a href='http://www.lutherregister.news/2018/09/'>September 2018</a>&nbsp;(34)</li>
	<li><a href='http://www.lutherregister.news/2018/08/'>August 2018</a>&nbsp;(45)</li>
	<li><a href='http://www.lutherregister.news/2018/07/'>July 2018</a>&nbsp;(27)</li>
	<li><a href='http://www.lutherregister.news/2018/06/'>June 2018</a>&nbsp;(31)</li>
	<li><a href='http://www.lutherregister.news/2018/05/'>May 2018</a>&nbsp;(20)</li>
	<li><a href='http://www.lutherregister.news/2018/04/'>April 2018</a>&nbsp;(15)</li>
	<li><a href='http://www.lutherregister.news/2018/03/'>March 2018</a>&nbsp;(31)</li>
	<li><a href='http://www.lutherregister.news/2018/02/'>February 2018</a>&nbsp;(14)</li>
	<li><a href='http://www.lutherregister.news/2018/01/'>January 2018</a>&nbsp;(13)</li>
	<li><a href='http://www.lutherregister.news/2017/12/'>December 2017</a>&nbsp;(15)</li>
	<li><a href='http://www.lutherregister.news/2017/11/'>November 2017</a>&nbsp;(22)</li>
	<li><a href='http://www.lutherregister.news/2017/10/'>October 2017</a>&nbsp;(24)</li>
	<li><a href='http://www.lutherregister.news/2017/09/'>September 2017</a>&nbsp;(18)</li>
	<li><a href='http://www.lutherregister.news/2017/08/'>August 2017</a>&nbsp;(23)</li>
	<li><a href='http://www.lutherregister.news/2017/07/'>July 2017</a>&nbsp;(17)</li>
	<li><a href='http://www.lutherregister.news/2017/06/'>June 2017</a>&nbsp;(20)</li>
	<li><a href='http://www.lutherregister.news/2017/05/'>May 2017</a>&nbsp;(18)</li>
	<li><a href='http://www.lutherregister.news/2017/04/'>April 2017</a>&nbsp;(32)</li>
	<li><a href='http://www.lutherregister.news/2017/03/'>March 2017</a>&nbsp;(29)</li>
	<li><a href='http://www.lutherregister.news/2017/02/'>February 2017</a>&nbsp;(27)</li>
	<li><a href='http://www.lutherregister.news/2017/01/'>January 2017</a>&nbsp;(27)</li>
	<li><a href='http://www.lutherregister.news/2016/12/'>December 2016</a>&nbsp;(19)</li>
	<li><a href='http://www.lutherregister.news/2016/11/'>November 2016</a>&nbsp;(27)</li>
	<li><a href='http://www.lutherregister.news/2016/10/'>October 2016</a>&nbsp;(45)</li>
	<li><a href='http://www.lutherregister.news/2016/09/'>September 2016</a>&nbsp;(29)</li>
	<li><a href='http://www.lutherregister.news/2016/08/'>August 2016</a>&nbsp;(29)</li>
	<li><a href='http://www.lutherregister.news/2016/07/'>July 2016</a>&nbsp;(27)</li>
	<li><a href='http://www.lutherregister.news/2016/06/'>June 2016</a>&nbsp;(22)</li>
	<li><a href='http://www.lutherregister.news/2016/05/'>May 2016</a>&nbsp;(27)</li>
	<li><a href='http://www.lutherregister.news/2016/04/'>April 2016</a>&nbsp;(25)</li>
	<li><a href='http://www.lutherregister.news/2016/03/'>March 2016</a>&nbsp;(18)</li>
	<li><a href='http://www.lutherregister.news/2016/02/'>February 2016</a>&nbsp;(24)</li>
	<li><a href='http://www.lutherregister.news/2016/01/'>January 2016</a>&nbsp;(20)</li>
	<li><a href='http://www.lutherregister.news/2015/12/'>December 2015</a>&nbsp;(16)</li>
	<li><a href='http://www.lutherregister.news/2015/11/'>November 2015</a>&nbsp;(17)</li>
		</ul>
			<div class="clearfix"></div></div><!-- .widget /-->		<div id="recent-posts-3" class="container-wrapper widget widget_recent_entries">		<div class="widget-title the-global-title has-block-head-4"><h4>Recent Posts<span class="widget-title-icon fa"></span></h4></div>		<ul>
											<li>
					<a href="http://www.lutherregister.news/2020/02/07/election-2020-sharp-draws-primary-challenger/" aria-current="page">ELECTION 2020: Sharp Draws Primary Challenger</a>
									</li>
											<li>
					<a href="http://www.lutherregister.news/2020/02/06/column-legislative-update/">COLUMN: Legislative Update</a>
									</li>
											<li>
					<a href="http://www.lutherregister.news/2020/02/04/register-by-february-7-to-vote-in-presidential-primary/">Register by February 7 to Vote in Presidential Primary</a>
									</li>
											<li>
					<a href="http://www.lutherregister.news/2020/02/04/wanted-luther-code-enforcement-officer/">WANTED: Luther Code Enforcement Officer</a>
									</li>
											<li>
					<a href="http://www.lutherregister.news/2020/02/02/luther-school-board-candidate-forum/">Luther School Board Candidate Forum</a>
									</li>
					</ul>
		<div class="clearfix"></div></div><!-- .widget /-->		</div><!-- .theiaStickySidebar /-->
	</aside><!-- .sidebar /-->
	
				</div><!-- .main-content-row /-->
			</div><!-- #content /-->
		
<footer id="footer" class="site-footer dark-skin dark-widgetized-area">

	
			<div id="footer-widgets-container">
				<div class="container">
					

		<div class="footer-widget-area ">
			<div class="tie-row">

									<div class="tie-col-sm-4 normal-side">
						<div id="bs_zones-9" class="container-wrapper widget bs_zones"><div><broadstreet-zone zone-id="68481" keywords="not_home_page,not_landing_page,is_article_page,community,election-2020,government,election-2020-sharp-draws-primary-challenger,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><div class="clearfix"></div></div><!-- .widget /-->					</div><!-- .tie-col /-->
				
				
				
				
			</div><!-- .tie-row /-->
		</div><!-- .footer-widget-area /-->

		
				</div><!-- .container /-->
			</div><!-- #Footer-widgets-container /-->
			
			<div id="site-info" class="site-info site-info-layout-2">
				<div class="container">
					<div class="tie-row">
						<div class="tie-col-md-12">

							<div class="copyright-text copyright-text-first">&copy; Copyright 2020, All Rights Reserved &nbsp;| Luther Register News</div><ul class="social-icons"><li class="social-icons-item"><a class="social-link  facebook-social-icon" title="Facebook" rel="nofollow noopener" target="_blank" href="https://www.facebook.com/lutherregister.news/"><span class="fa fa-facebook"></span></a></li><li class="social-icons-item"><a class="social-link  twitter-social-icon" title="Twitter" rel="nofollow noopener" target="_blank" href="https://twitter.com/berryholler"><span class="fa fa-twitter"></span></a></li><li class="social-icons-item"><a class="social-link  instagram-social-icon" title="Instagram" rel="nofollow noopener" target="_blank" href="https://www.instagram.com/lutherregisternews/"><span class="fa fa-instagram"></span></a></li><li class="social-icons-item"><a class="social-link  rss-social-icon" title="RSS" rel="nofollow noopener" target="_blank" href="http://www.lutherregister.news/feed/"><span class="fa fa-rss"></span></a></li></ul> 

						</div><!-- .tie-col /-->
					</div><!-- .tie-row /-->
				</div><!-- .container /-->
			</div><!-- #site-info /-->
			
</footer><!-- #footer /-->


		<div class="post-footer post-footer-on-mobile">
			<div class="share-links  icons-only">
				<a href="https://www.facebook.com/sharer.php?u=https://wp.me/p6TWr2-53H" rel="external noopener" target="_blank" class="facebook-share-btn"><span class="fa fa-facebook"></span> <span class="screen-reader-text">Facebook</span></a><a href="https://twitter.com/intent/tweet?text=ELECTION+2020%3A+Sharp+Draws+Primary+Challenger&#038;url=https://wp.me/p6TWr2-53H&#038;via=@berryholler" rel="external noopener" target="_blank" class="twitter-share-btn"><span class="fa fa-twitter"></span> <span class="screen-reader-text">Twitter</span></a><a href="https://plusone.google.com/_/+1/confirm?hl=en&#038;url=https://wp.me/p6TWr2-53H&#038;name=ELECTION+2020%3A+Sharp+Draws+Primary+Challenger" rel="external noopener" target="_blank" class="google-share-btn"><span class="fa fa-google"></span> <span class="screen-reader-text">Google+</span></a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://wp.me/p6TWr2-53H&#038;title=ELECTION+2020%3A+Sharp+Draws+Primary+Challenger" rel="external noopener" target="_blank" class="linkedin-share-btn"><span class="fa fa-linkedin"></span> <span class="screen-reader-text">LinkedIn</span></a><a href="whatsapp://send?text=ELECTION+2020%3A+Sharp+Draws+Primary+Challenger - https://wp.me/p6TWr2-53H" rel="external noopener" target="_blank" class="whatsapp-share-btn"><span class="fa fa-whatsapp"></span> <span class="screen-reader-text">WhatsApp</span></a><a href="tg://msg?text=ELECTION+2020%3A+Sharp+Draws+Primary+Challenger - https://wp.me/p6TWr2-53H" rel="external noopener" target="_blank" class="telegram-share-btn"><span class="fa fa-paper-plane"></span> <span class="screen-reader-text">Telegram</span></a>			</div><!-- .share-links /-->
		</div><!-- .post-footer-on-top /-->

		<div class="mobile-share-buttons-spacer"></div>
		<a id="go-to-top" class="go-to-top-button" href="#go-to-tie-body">
			<span class="fa fa-angle-up"></span>
			<span class="screen-reader-text">Back to top button</span>
		</a>
		<div class="clear"></div>
	
		</div><!-- #tie-wrapper /-->

		

	<aside class="side-aside normal-side tie-aside-effect dark-skin dark-widgetized-area is-fullwidth" aria-label="Secondary Sidebar">
		<div data-height="100%" class="side-aside-wrapper has-custom-scroll">

			<a href="#" class="close-side-aside remove big-btn light-btn">
				<span class="screen-reader-text">Close</span>
			</a><!-- .close-side-aside /-->

			<div id="mobile-container">

				
				<div id="mobile-menu" class="">

					
				</div><!-- #mobile-menu /-->

				<div class="mobile-social-search">
											<div id="mobile-social-icons" class="social-icons-widget solid-social-icons">
							<ul><li class="social-icons-item"><a class="social-link  facebook-social-icon" title="Facebook" rel="nofollow noopener" target="_blank" href="https://www.facebook.com/lutherregister.news/"><span class="fa fa-facebook"></span></a></li><li class="social-icons-item"><a class="social-link  twitter-social-icon" title="Twitter" rel="nofollow noopener" target="_blank" href="https://twitter.com/berryholler"><span class="fa fa-twitter"></span></a></li><li class="social-icons-item"><a class="social-link  instagram-social-icon" title="Instagram" rel="nofollow noopener" target="_blank" href="https://www.instagram.com/lutherregisternews/"><span class="fa fa-instagram"></span></a></li><li class="social-icons-item"><a class="social-link  rss-social-icon" title="RSS" rel="nofollow noopener" target="_blank" href="http://www.lutherregister.news/feed/"><span class="fa fa-rss"></span></a></li></ul> 
						</div><!-- #mobile-social-icons /-->
												<div id="mobile-search">
							<form role="search" method="get" class="search-form" action="http://www.lutherregister.news/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</div><!-- #mobile-search /-->
										</div><!-- #mobile-social-search /-->

			</div><!-- #mobile-container /-->


			
				<div id="slide-sidebar-widgets">
					<div id="search-2" class="container-wrapper widget widget_search"><form role="search" method="get" class="search-form" action="http://www.lutherregister.news/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form><div class="clearfix"></div></div><!-- .widget /--><div id="tie-newsletter-2" class="container-wrapper widget subscribe-widget"><div class="widget-title the-global-title has-block-head-4"><h4>Newsletter<span class="widget-title-icon fa"></span></h4></div>
			<div class="widget-inner-wrap">

										<span class="fa fa-envelope newsletter-icon" aria-hidden="true"></span>
												<div class="subscribe-widget-content">
							<h3>Subscribe to our mailing list to get the new updates!</h3>						</div>
												<div id="mc_embed_signup-tie-newsletter-2">
							<form action="https://news.us15.list-manage.com/subscribe/post?u=71e8fa22d398857d731048211&amp;id=b4a5b22b0c" method="post" id="mc-embedded-subscribe-form-tie-newsletter-2" name="mc-embedded-subscribe-form" class="subscribe-form validate" target="_blank" novalidate>
									<div class="mc-field-group">
										<label class="screen-reader-text" for="mce-EMAIL-tie-newsletter-2">Enter your Email address</label>
										<input type="email" value="" id="mce-EMAIL-tie-newsletter-2" placeholder="Enter your Email address" name="EMAIL" class="subscribe-input required email">
									</div>
									<input type="submit" value="Subscribe" name="subscribe" class="button subscribe-submit">
							</form>
						</div>
						
			</div><!-- .widget-inner-wrap /-->

			<div class="clearfix"></div></div><!-- .widget /-->		<div id="recent-posts-2" class="container-wrapper widget widget_recent_entries">		<div class="widget-title the-global-title has-block-head-4"><h4>Recent Posts<span class="widget-title-icon fa"></span></h4></div>		<ul>
											<li>
					<a href="http://www.lutherregister.news/2020/02/07/election-2020-sharp-draws-primary-challenger/" aria-current="page">ELECTION 2020: Sharp Draws Primary Challenger</a>
									</li>
											<li>
					<a href="http://www.lutherregister.news/2020/02/06/column-legislative-update/">COLUMN: Legislative Update</a>
									</li>
											<li>
					<a href="http://www.lutherregister.news/2020/02/04/register-by-february-7-to-vote-in-presidential-primary/">Register by February 7 to Vote in Presidential Primary</a>
									</li>
											<li>
					<a href="http://www.lutherregister.news/2020/02/04/wanted-luther-code-enforcement-officer/">WANTED: Luther Code Enforcement Officer</a>
									</li>
											<li>
					<a href="http://www.lutherregister.news/2020/02/02/luther-school-board-candidate-forum/">Luther School Board Candidate Forum</a>
									</li>
					</ul>
		<div class="clearfix"></div></div><!-- .widget /--><div id="archives-2" class="container-wrapper widget widget_archive"><div class="widget-title the-global-title has-block-head-4"><h4>Archives<span class="widget-title-icon fa"></span></h4></div>		<ul>
				<li><a href='http://www.lutherregister.news/2020/02/'>February 2020</a></li>
	<li><a href='http://www.lutherregister.news/2020/01/'>January 2020</a></li>
	<li><a href='http://www.lutherregister.news/2019/12/'>December 2019</a></li>
	<li><a href='http://www.lutherregister.news/2019/11/'>November 2019</a></li>
	<li><a href='http://www.lutherregister.news/2019/10/'>October 2019</a></li>
	<li><a href='http://www.lutherregister.news/2019/09/'>September 2019</a></li>
	<li><a href='http://www.lutherregister.news/2019/08/'>August 2019</a></li>
	<li><a href='http://www.lutherregister.news/2019/07/'>July 2019</a></li>
	<li><a href='http://www.lutherregister.news/2019/06/'>June 2019</a></li>
	<li><a href='http://www.lutherregister.news/2019/05/'>May 2019</a></li>
	<li><a href='http://www.lutherregister.news/2019/04/'>April 2019</a></li>
	<li><a href='http://www.lutherregister.news/2019/03/'>March 2019</a></li>
	<li><a href='http://www.lutherregister.news/2019/02/'>February 2019</a></li>
	<li><a href='http://www.lutherregister.news/2019/01/'>January 2019</a></li>
	<li><a href='http://www.lutherregister.news/2018/12/'>December 2018</a></li>
	<li><a href='http://www.lutherregister.news/2018/11/'>November 2018</a></li>
	<li><a href='http://www.lutherregister.news/2018/10/'>October 2018</a></li>
	<li><a href='http://www.lutherregister.news/2018/09/'>September 2018</a></li>
	<li><a href='http://www.lutherregister.news/2018/08/'>August 2018</a></li>
	<li><a href='http://www.lutherregister.news/2018/07/'>July 2018</a></li>
	<li><a href='http://www.lutherregister.news/2018/06/'>June 2018</a></li>
	<li><a href='http://www.lutherregister.news/2018/05/'>May 2018</a></li>
	<li><a href='http://www.lutherregister.news/2018/04/'>April 2018</a></li>
	<li><a href='http://www.lutherregister.news/2018/03/'>March 2018</a></li>
	<li><a href='http://www.lutherregister.news/2018/02/'>February 2018</a></li>
	<li><a href='http://www.lutherregister.news/2018/01/'>January 2018</a></li>
	<li><a href='http://www.lutherregister.news/2017/12/'>December 2017</a></li>
	<li><a href='http://www.lutherregister.news/2017/11/'>November 2017</a></li>
	<li><a href='http://www.lutherregister.news/2017/10/'>October 2017</a></li>
	<li><a href='http://www.lutherregister.news/2017/09/'>September 2017</a></li>
	<li><a href='http://www.lutherregister.news/2017/08/'>August 2017</a></li>
	<li><a href='http://www.lutherregister.news/2017/07/'>July 2017</a></li>
	<li><a href='http://www.lutherregister.news/2017/06/'>June 2017</a></li>
	<li><a href='http://www.lutherregister.news/2017/05/'>May 2017</a></li>
	<li><a href='http://www.lutherregister.news/2017/04/'>April 2017</a></li>
	<li><a href='http://www.lutherregister.news/2017/03/'>March 2017</a></li>
	<li><a href='http://www.lutherregister.news/2017/02/'>February 2017</a></li>
	<li><a href='http://www.lutherregister.news/2017/01/'>January 2017</a></li>
	<li><a href='http://www.lutherregister.news/2016/12/'>December 2016</a></li>
	<li><a href='http://www.lutherregister.news/2016/11/'>November 2016</a></li>
	<li><a href='http://www.lutherregister.news/2016/10/'>October 2016</a></li>
	<li><a href='http://www.lutherregister.news/2016/09/'>September 2016</a></li>
	<li><a href='http://www.lutherregister.news/2016/08/'>August 2016</a></li>
	<li><a href='http://www.lutherregister.news/2016/07/'>July 2016</a></li>
	<li><a href='http://www.lutherregister.news/2016/06/'>June 2016</a></li>
	<li><a href='http://www.lutherregister.news/2016/05/'>May 2016</a></li>
	<li><a href='http://www.lutherregister.news/2016/04/'>April 2016</a></li>
	<li><a href='http://www.lutherregister.news/2016/03/'>March 2016</a></li>
	<li><a href='http://www.lutherregister.news/2016/02/'>February 2016</a></li>
	<li><a href='http://www.lutherregister.news/2016/01/'>January 2016</a></li>
	<li><a href='http://www.lutherregister.news/2015/12/'>December 2015</a></li>
	<li><a href='http://www.lutherregister.news/2015/11/'>November 2015</a></li>
		</ul>
			<div class="clearfix"></div></div><!-- .widget /--><div id="categories-2" class="container-wrapper widget widget_categories"><div class="widget-title the-global-title has-block-head-4"><h4>Categories<span class="widget-title-icon fa"></span></h4></div>		<ul>
				<li class="cat-item cat-item-48"><a href="http://www.lutherregister.news/category/advertising/">Advertising</a>
</li>
	<li class="cat-item cat-item-1284"><a href="http://www.lutherregister.news/category/arcadia/">Arcadia</a>
</li>
	<li class="cat-item cat-item-254"><a href="http://www.lutherregister.news/category/book-review/">Book Review</a>
</li>
	<li class="cat-item cat-item-18"><a href="http://www.lutherregister.news/category/business/">Business</a>
</li>
	<li class="cat-item cat-item-38"><a href="http://www.lutherregister.news/category/community/">Community</a>
</li>
	<li class="cat-item cat-item-101"><a href="http://www.lutherregister.news/category/crime/">Crime</a>
</li>
	<li class="cat-item cat-item-1699"><a href="http://www.lutherregister.news/category/deep-fork-district/">Deep Fork District</a>
</li>
	<li class="cat-item cat-item-39"><a href="http://www.lutherregister.news/category/education/">Education</a>
</li>
	<li class="cat-item cat-item-43"><a href="http://www.lutherregister.news/category/election-2016/">Election 2016</a>
</li>
	<li class="cat-item cat-item-50"><a href="http://www.lutherregister.news/category/election-2017/">Election 2017</a>
</li>
	<li class="cat-item cat-item-908"><a href="http://www.lutherregister.news/category/election-2018/">Election 2018</a>
</li>
	<li class="cat-item cat-item-1459"><a href="http://www.lutherregister.news/category/election-2019/">Election 2019</a>
</li>
	<li class="cat-item cat-item-1639"><a href="http://www.lutherregister.news/category/election-2020/">Election 2020</a>
</li>
	<li class="cat-item cat-item-58"><a href="http://www.lutherregister.news/category/faith/">Faith</a>
</li>
	<li class="cat-item cat-item-49"><a href="http://www.lutherregister.news/category/fire/">Fire</a>
</li>
	<li class="cat-item cat-item-1373"><a href="http://www.lutherregister.news/category/food/">Food</a>
</li>
	<li class="cat-item cat-item-479"><a href="http://www.lutherregister.news/category/government/">Government</a>
</li>
	<li class="cat-item cat-item-24"><a href="http://www.lutherregister.news/category/health/">Health</a>
</li>
	<li class="cat-item cat-item-196"><a href="http://www.lutherregister.news/category/letter-to-the-editor/">Letter to the Editor</a>
</li>
	<li class="cat-item cat-item-801"><a href="http://www.lutherregister.news/category/obituary/">Obituary</a>
</li>
	<li class="cat-item cat-item-1392"><a href="http://www.lutherregister.news/category/oklahoma-county/">Oklahoma County</a>
</li>
	<li class="cat-item cat-item-25"><a href="http://www.lutherregister.news/category/opinion/">Opinion</a>
</li>
	<li class="cat-item cat-item-1029"><a href="http://www.lutherregister.news/category/pecan-festival/">Pecan Festival</a>
</li>
	<li class="cat-item cat-item-55"><a href="http://www.lutherregister.news/category/police/">Police</a>
</li>
	<li class="cat-item cat-item-26"><a href="http://www.lutherregister.news/category/politics/">Politics</a>
</li>
	<li class="cat-item cat-item-27"><a href="http://www.lutherregister.news/category/science/">Science</a>
</li>
	<li class="cat-item cat-item-28"><a href="http://www.lutherregister.news/category/sports/">Sports</a>
</li>
	<li class="cat-item cat-item-978"><a href="http://www.lutherregister.news/category/tourism/">Tourism</a>
</li>
	<li class="cat-item cat-item-37"><a href="http://www.lutherregister.news/category/town/">Town</a>
</li>
	<li class="cat-item cat-item-30"><a href="http://www.lutherregister.news/category/travel/">Travel</a>
</li>
	<li class="cat-item cat-item-77"><a href="http://www.lutherregister.news/category/turnpike/">Turnpike</a>
</li>
	<li class="cat-item cat-item-1"><a href="http://www.lutherregister.news/category/uncategorized/">Uncategorized</a>
</li>
		</ul>
			<div class="clearfix"></div></div><!-- .widget /-->				</div>
			
		</div><!-- .side-aside-wrapper /-->
	</aside><!-- .side-aside /-->

	
	</div><!-- #tie-container /-->
</div><!-- .background-overlay /-->

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','community','election-2020','government','election-2020-sharp-draws-primary-challenger','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["community","election-2020","government","election-2020-sharp-draws-primary-challenger","post"],"url":"election-2020-sharp-draws-primary-challenger"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(5764);
 });</script><div id="reading-position-indicator"></div><div id="fb-root"></div>	<div id="tie-popup-login" class="tie-popup">
		<a href="#" class="tie-btn-close remove big-btn light-btn">
			<span class="screen-reader-text">Close</span>
		</a>
		<div class="tie-popup-container">
			<div class="container-wrapper">
				<div class="widget login-widget">

					
					<div class="widget-title the-global-title has-block-head-4">
						<h4>Log In <span class="widget-title-icon fa "></span>
						</h4>
					</div>

					<div class="widget-container">
						
			<div class="login-form">

				<form name="registerform" action="http://www.lutherregister.news/wp-login.php" method="post">
					<input type="text" name="log" title="Username" placeholder="Username">
					<div class="pass-container">
						<input type="password" name="pwd" title="Password" placeholder="Password">
						<a class="forget-text" href="http://www.lutherregister.news/my-account/lost-password/">Forget?</a>
					</div>

					<input type="hidden" name="redirect_to" value="/2020/02/07/election-2020-sharp-draws-primary-challenger/"/>
					<label for="rememberme" class="rememberme">
						<input id="rememberme" name="rememberme" type="checkbox" checked="checked" value="forever" /> Remember me					</label>

					
					
					<button type="submit" class="button fullwidth login-submit">Log In</button>

									</form>

				
			</div>
								</div><!-- .widget-container  /-->
				</div><!-- .login-widget  /-->
			</div><!-- .container-wrapper  /-->
		</div><!-- .tie-popup-container /-->
	</div><!-- .tie-popup /-->
					<div id="tie-popup-adblock" class="tie-popup is-fixed-popup">
					<div class="tie-popup-container">
						<div class="container-wrapper">
						<span class="fa fa-ban" aria-hidden="true"></span>
						<h2>Adblock Detected</h2>
						<div class="adblock-message">Please consider supporting us by disabling your ad blocker</div>
						</div><!-- .container-wrapper  /-->
					</div><!-- .tie-popup-container /-->
				</div><!-- .tie-popup /-->
				<script type='text/javascript' src='http://www.lutherregister.news/wp-content/themes/jannah/assets/js/advertisement.js'></script>
				<script type="text/javascript">
		var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;
	</script>
	<script type='text/javascript' src='http://www.lutherregister.news/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"http:\/\/www.lutherregister.news\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js'></script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_3a9b739e9ffc1c51c3bc80ba75c2b36d","fragment_name":"wc_fragments_3a9b739e9ffc1c51c3bc80ba75c2b36d","request_timeout":"5000"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js'></script>
<script type='text/javascript'>
		jQuery( 'body' ).bind( 'wc_fragments_refreshed', function() {
			jQuery( 'body' ).trigger( 'jetpack-lazy-images-load' );
		} );
	
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var mailchimp_public_data = {"site_url":"http:\/\/www.lutherregister.news","ajax_url":"http:\/\/www.lutherregister.news\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-content/plugins/mailchimp-for-woocommerce/public/js/mailchimp-woocommerce-public.min.js'></script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-content/plugins/bloom/core/admin/js/common.js'></script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-content/themes/jannah/assets/js/scripts.js'></script>
<script type='text/javascript'>
				jQuery.ajax({
					type : "GET",
					url  : "http://www.lutherregister.news/wp-admin/admin-ajax.php",
					data : "postviews_id=19449&action=tie_postviews",
					cache: !1
				});
			
</script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-includes/js/imagesloaded.min.js'></script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='http://www.lutherregister.news/wp-content/themes/jannah/assets/js/sliders.js'></script>
<script async="async" type='text/javascript' src='http://www.lutherregister.news/wp-content/plugins/akismet/_inc/form.js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202006.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.1',blog:'101990684',post:'19449',tz:'-6',srv:'www.lutherregister.news'} ]);
	_stq.push([ 'clickTrackerInit', '101990684', '19449' ]);
</script>
<style type="text/css"></style></body>
</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1581131317 -->